CommCareHQ: Degraded Site Performance
Incident Report for CommCare HQ
Resolved
Dear users, this incident has been resolved. Thank you for your patience while we worked to resolve it.
Posted 17 days ago. May 06, 2019 - 10:45 UTC
Investigating
Dear Users,

We’re experiencing performance issues on commcarehq.org, and some users may notice the maintenance page when trying to access CommCareHQ. Our engineers are looking into this problem. We sincerely apologize for the inconvenience caused due to this.
Posted 17 days ago. May 06, 2019 - 10:14 UTC