Degraded performance affecting case management on www.commcarehq.org

Incident Report for CommCare HQ

Resolved

We have seen a full recovery and consider this issue resolved. Thank you for your patience. Please reach out to support@dimagi.com with any questions or concerns.
Posted Feb 24, 2026 - 22:48 UTC

Monitoring

We've implemented a fix for this issue and will continue to monitor the situation to ensure full recovery. We will continue to keep you updated until this is resolved.
Posted Feb 24, 2026 - 22:31 UTC

Identified

Dear Users,

We have identified an issue on www.commcarehq.org affecting case management causing degraded performance. We have identified the root cause of the issue and are working on implementing a fix. Thank you for your patience and we apologize for any inconvenience caused. Please reach out to support@dimagi.com with any questions or concerns.
Posted Feb 24, 2026 - 22:01 UTC
This incident affected: www.commcarehq.org (Core Functionality).