Degraded performance affecting lookup tables

Incident Report for CommCare HQ

Resolved

Dear Users,

Our developers were able to implement a fix for this issue. If you continue to experience the error, please sync your application. We sincerely apologize for any inconvenience caused and appreciate your patience while we worked toward the resolution of this issue. Please reach out to support@dimagi.com with any further questions.
Posted May 13, 2025 - 17:00 UTC

Update

Dear users,

Our developers are actively working on implementing the fix. We will continue to update the status of this issue to provide the most up to date information.
Posted May 13, 2025 - 15:08 UTC

Identified

Dear users,

We've identified that the issue is related to indexed lookup tables. Our team is actively working on a fix and will provide another update within the next hour. We apologize for the inconvenience and appreciate your patience.
Posted May 13, 2025 - 14:18 UTC

Investigating

Dear users,

We’re currently investigating an issue affecting Lookup Tables on CommCare HQ. Some users may encounter errors where lookup tables fail to load or sync as expected.

Our engineering team is actively working to identify and resolve the root cause. In the meantime, a temporary workaround is available: re-saving the affected lookup table by going to Manage Lookup Tables, selecting Edit, and clicking Save. This action appears to restore normal functionality in most cases.

We apologize for the inconvenience and appreciate your patience as we work to restore full functionality. We’ll continue to provide updates as progress is made.
Posted May 13, 2025 - 12:33 UTC