Issue with Case Import History
Incident Report for CommCare HQ
Resolved
This incident has been resolved.
Posted 18 days ago. May 29, 2019 - 17:21 UTC
Identified
Dear users, we have identified an issue with the case import history page. You may notice that your case import history is not loading correctly. We have a fix in place for this, and this should be resolved in the next few hours. We apologize for the inconvenience.
Posted 18 days ago. May 29, 2019 - 17:07 UTC
This incident affected: www.commcarehq.org (Bulk Case Import).