Android 4.1 - 4.4 devices must update to the latest CommCare version (2.48.7)
Incident Report for CommCare HQ
Resolved
Any users on Android 4.1 - 4.4 must update to the latest release of CommCare (2.48.7) or they will not be able to interact with Dimagi’s SaaS CommCare server for installs, submissions, or syncs.

In a review of our cloud security configurations, we removed an SSL encryption cipher which is no longer considered sufficiently strong by industry best practices. We’ve since identified that the set of SSL protocols which are in best practice does not include any of the protocols which are included by the operating system by default on Android 4.1-4.4 devices.

We have performed a hotfix of the mobile application to manually supply a secure communication layer which meets industry standards that is available on the Play Store.

If you have any questions or concerns, please reach out to the Dimagi Support Team at support@dimagi.com
Posted May 25, 2020 - 20:12 UTC
Monitoring
Any users on Android 4.1 - 4.4 must update to the latest release of CommCare (2.48.7) or they will not be able to interact with Dimagi’s SaaS CommCare server for installs, submissions, or syncs.

In a review of our cloud security configurations, we removed an SSL encryption cipher which is no longer considered sufficiently strong by industry best practices. We’ve since identified that the set of SSL protocols which are in best practice does not include any of the protocols which are included by the operating system by default on Android 4.1-4.4 devices.

We have performed a hotfix of the mobile application to manually supply a secure communication layer which meets industry standards that is available on the Play Store.

If you have any questions or concerns, please reach out to the Dimagi Support Team at support@dimagi.com
Posted May 22, 2020 - 14:09 UTC
This incident affected: www.commcarehq.org (Syncs with CommCare HQ, Form Submissions).