www.commcarehq.org: Continuing issue on mobile workers page
Incident Report for CommCare HQ
Resolved
Dear users, this issue has now been resolved. We greatly apologize for the inconvenience this might have caused you!
Posted about 1 month ago. Jul 17, 2019 - 15:35 UTC
Monitoring
Dear all, some of our users may still be experiencing an issue while loading the mobile workers page. We've implemented a fix, and are monitoring the site for further improvements. In the meantime, if you continue to experience the issue, please try a hard refresh on the page by pressing (CTRL + SHIFT + R) keys on your keyboard. We sincerely apologize for the inconvenience caused by this issue.
Posted about 1 month ago. Jul 17, 2019 - 14:16 UTC
This incident affected: www.commcarehq.org (User Management).